CVEvulnerability
CVE-2026-40352
8.8 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-04-17
- Last modified
- 2026-10-26
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-943
Description
FastGPT is an AI Agent building platform. In versions prior to 4.14.9.5, the password change endpoint is vulnerable to NoSQL injection. An authenticated attacker can bypass the "old password" verification by injecting MongoDB query operators. This allows an attacker who has gained a low-privileged session to change the password of their account (or others if combined with ID manipulation) without knowing the current one, leading to full account takeover and persistence. This issue has been fixed in version 4.14.9.5.
Affected configurations
• fastgpt fastgpt (< 4.14.9.5)
Related
Weakness · CWE (1)
- CWE-943 Improper Neutralization of Special Elements in Data Query Logic weakness
References
- https://github.com/labring/FastGPT/commit/bd966d479fbe414d02679cf79f9eaaab3d100a2d Patch
- https://github.com/labring/FastGPT/releases/tag/v4.14.9.5 Product, Release Notes
- https://github.com/labring/FastGPT/security/advisories/GHSA-422w-vrfj-72g6 Exploit, Vendor Advisory