CVEvulnerability
CVE-2026-40976
9.1 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2026-04-28
- Last modified
- 2026-07-24
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 9.1 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- CVSS 3.1 (0b0ca135-0b70-47e7-9f44-1890c2a1c46c)
- 9.1 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-305, CWE-862
Description
In certain circumstances, Spring Boot's default web security is ineffective allowing unauthorized access to all endpoints. For an application to be vulnerable, it must: be a servlet-based web application; have no Spring Security configuration of its own and rely on the default web security filter chain; depend on spring-boot-actuator-autoconfigure; not depend on spring-boot-health. If any of the above does not apply, the application is not vulnerable.
Affected: Spring Boot 4.0.0–4.0.5; upgrade to 4.0.6 or later per vendor advisory.
Affected configurations
• vmware spring boot (>= 4.0.0 < 4.0.6)
Related
References
- https://spring.io/security/cve-2026-40976 Vendor Advisory
- https://access.redhat.com/security/cve/CVE-2026-40976 access.redhat.com
- https://bugzilla.redhat.com/show_bug.cgi?id=2463322 bugzilla.redhat.com
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-40976.json security.access.redhat.com