CVEvulnerability
CVE-2026-41043
6.5 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2026-04-24
- Last modified
- 2026-10-26
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- Weaknesses
- CWE-79, CWE-915
Description
Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in Apache ActiveMQ, Apache ActiveMQ Web.
An authenticated attacker can show malicious content when browsing queues in the web console by overriding the content type to be HTML (instead of XML) and by injecting HTML into a JMS selector field.
This issue affects Apache ActiveMQ: before 5.19.6, from 6.0.0 before 6.2.5; Apache ActiveMQ Web: before 5.19.6, from 6.0.0 before 6.2.5.
Users are recommended to upgrade to version 6.2.5 or 5.19.6, which fixes the issue.
Affected configurations
• apache activemq (< 5.19.6)
• apache activemq (>= 6.0.0 < 6.2.5)
• apache activemq web (< 5.19.6)
• apache activemq web (>= 6.0.0 < 6.2.5)