CVEvulnerability
CVE-2026-41138
8.8 HIGH
Official page ↗
- Status
- Modified
- Published
- 2026-04-23
- Last modified
- 2026-10-26
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CVSS 3.0 ([email protected])
- 8.3 HIGH — CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L
- Weaknesses
- CWE-94
Description
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, there is a remote code execution vulnerability in AirtableAgent.ts caused by lack of input verification when using Pandas. The user’s input is directly applied to the question parameter within the prompt template and it is reflected to the Python code without any sanitization. This vulnerability is fixed in 3.1.0.
Affected configurations
• flowiseai flowise (< 3.1.0)
Related
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness
References
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-f228-chmx-v6j6 Exploit, Vendor Advisory
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-f228-chmx-v6j6 Exploit, Vendor Advisory