CVEvulnerability
CVE-2026-41643
7.5 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-05-07
- Last modified
- 2026-10-26
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-129
Description
GoBGP is an open source Border Gateway Protocol (BGP) implementation in the Go Programming Language. Prior to version 4.3.0, a remote Denial of Service (DoS) vulnerability exists in GoBGP where a malformed BGP UPDATE message can trigger a runtime error: index out of range panic. This occurs during the processing of 4-byte AS attributes when the message structure causes an internal slice index shift that is not properly handled. This issue has been patched in version 4.3.0.
Affected configurations
• osrg gobgp (< 4.3.0)
Related
Weakness · CWE (1)
- CWE-129 Improper Validation of Array Index weakness
References
- https://github.com/osrg/gobgp/releases/tag/v4.3.0 Patch, Release Notes
- https://github.com/osrg/gobgp/security/advisories/GHSA-8rxh-r2p6-7f2q Exploit, Vendor Advisory
- https://github.com/osrg/gobgp/security/advisories/GHSA-8rxh-r2p6-7f2q Exploit, Vendor Advisory