CVEvulnerability

CVE-2026-41677

1.7 LOW Published 2026-04-24 Modified 2026-06-17 Official page ↗
Status
Analyzed
Published
2026-04-24
Last modified
2026-06-17
Assigner
[email protected]
CVSS 4.0 ([email protected])
1.7 LOW — CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N/E:U/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1 ([email protected])
9.1 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
Weaknesses
CWE-125, CWE-1284

Description

rust-openssl provides OpenSSL bindings for the Rust programming language. From 0.9.0 to before 0.10.78, the *_from_pem_callback APIs did not validate the length returned by the user's callback. A password callback that returns a value larger than the buffer it was given can cause some versions of OpenSSL to over-read this buffer. OpenSSL 3.x is not affected by this. This vulnerability is fixed in 0.10.78.

Affected configurations

• rust-openssl project rust-openssl (>= 0.9.0 < 0.10.78)

Related

Weakness · CWE (2)

  • CWE-125 Out-of-bounds Read weakness
  • CWE-1284 Improper Validation of Specified Quantity in Input weakness

References