CVEvulnerability
CVE-2026-41705
8.6 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-05-09
- Last modified
- 2026-07-24
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.6 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L
- Weaknesses
- CWE-917
Description
Spring AI's MilvusVectorStore#doDelete(List) implementation is vulnerable to filter-expression injection via unsanitized document IDs.
Spring AI 1.0.x: affected from 1.0.0 through latest 1.0.x; upgrade to 1.0.7 or greater. Spring AI 1.1.x: affected from 1.1.0 through latest 1.1.x; upgrade to 1.1.6 or greater.
Affected configurations
• vmware spring ai (>= 1.0.0 < 1.0.7)
• vmware spring ai (>= 1.1.0 < 1.1.6)
Related
Weakness · CWE (1)
- CWE-917 Improper Neutralization of Special Elements used in an Expression Language Statement weakness
References
- https://spring.io/security/cve-2026-41705 Vendor Advisory