CVEvulnerability

CVE-2026-4176

9.8 CRITICAL Published 2026-03-29 Modified 2026-06-17 Official page ↗
Status
Analyzed
Published
2026-03-29
Last modified
2026-06-17
Assigner
9b29abf9-4ab0-4765-b253-1875cd9b441e
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

Perl versions from 5.9.4 before 5.40.4-RC1, from 5.41.0 before 5.42.2-RC1, from 5.43.0 before 5.43.9 contain a vulnerable version of Compress::Raw::Zlib. Compress::Raw::Zlib is included in the Perl package as a dual-life core module, and is vulnerable to CVE-2026-3381 due to a vendored version of zlib which has several vulnerabilities, including CVE-2026-27171. The bundled Compress::Raw::Zlib was updated to version 2.221 in Perl blead commit c75ae9cc164205e1b6d6dbd57bd2c65c8593fe94.

Affected configurations

• perl perl (>= 5.9.4 < 5.40.4) • perl perl (>= 5.41.0 < 5.42.2) • perl perl (>= 5.43.0 < 5.43.9)

References