CVEvulnerability
CVE-2026-41870
8.8 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-09-09
- Last modified
- 2026-09-11
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-470, CWE-862, CWE-913, CWE-94
Description
Missing Authorization, Improper Control of Generation of Code ('Code Injection'), Improper Control of Dynamically-Managed Code Resources, Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Apache Nutch Server (Nutch REST API).
This issue affects Apache Nutch: from 1.11 through 1.22.
Users are recommended to upgrade to version 1.23, which removes the Nutch Server.
If an upgrade is not possible, user must restrict access to instances running the Nutch Service to trusted users only.
Please, also visit the Apache Nutch security advisories https://nutch.apache.org/documentation/security/ .
Affected configurations
• apache nutch (>= 1.11 < 1.23)
Related
References
- https://lists.apache.org/thread/3pl59g0jzqx1bdh5w92qoftzn7c3x8j2 Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2026/09/08/4 Mailing List, Third Party Advisory