CVEvulnerability
CVE-2026-42055
9.2 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2026-06-17
- Last modified
- 2026-09-14
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 9.2 CRITICAL — CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 8.1 HIGH — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS 3.1 (0b0ca135-0b70-47e7-9f44-1890c2a1c46c)
- 8.1 HIGH — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-122, CWE-131, CWE-787
Description
NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_proxy_v2_module and ngx_http_grpc_module modules. This vulnerability exists when the proxy_http_version to 2 or grpc_pass directives are used to proxy HTTP/2 traffic, the ignore_invalid_headers directive is set to off, and the large_client_header_buffers directive size is larger than 2 megabytes. A remote, unauthenticated attacker, along with conditions beyond their control, could send large headers while creating an upstream request. This may cause a heap-based buffer overflow in the NGINX worker process leading to a restart. Additionally, attackers can execute code on systems with Address Space Layout Randomization (ASLR) disabled or when the attacker can bypass ASLR.
Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Affected configurations
• f5 dos (>= 4.3.0 <= 4.7.0)
• f5 dos 4.9.0
• f5 nginx gateway fabric (>= 1.3.0 <= 1.6.2)
• f5 nginx gateway fabric (>= 2.0.0 <= 2.6.3)
• f5 nginx ingress controller (>= 3.5.0 <= 3.7.2)
• f5 nginx ingress controller (>= 4.0.0 <= 4.0.1)
• f5 nginx ingress controller (>= 5.0.0 <= 5.5.0)
• f5 nginx instance manager (>= 2.17.0 <= 2.22.0)
• f5 nginx open source (>= 1.0.0 <= 1.30.2)
• f5 nginx open source (>= 1.31.0 <= 1.31.1)
• f5 nginx plus (>= 37.0.0.1 < 37.0.2.1)
• f5 nginx plus (>= r33 < r36)
• f5 nginx plus r36
• f5 waf (>= 4.10.0 <= 4.16.0)
• f5 waf (>= 5.2.0 <= 5.8.0)
• f5 waf (>= 5.9.0 <= 5.13.1)
• redhat discovery
• redhat hardened images
• redhat update infrastructure (>= 5.0 < 5.2)
• redhat enterprise linux 8.0
• redhat enterprise linux 9.0
• redhat enterprise linux 10.0
Related
References
- https://my.f5.com/manage/s/article/K000161584 Vendor Advisory
- https://access.redhat.com/errata/RHSA-2026:27197 Third Party Advisory
- https://access.redhat.com/errata/RHSA-2026:36331 Third Party Advisory
- https://access.redhat.com/errata/RHSA-2026:36364 Third Party Advisory
- https://access.redhat.com/errata/RHSA-2026:36618 Third Party Advisory
- https://access.redhat.com/errata/RHSA-2026:36639 Third Party Advisory
- https://access.redhat.com/errata/RHSA-2026:38847 Third Party Advisory
- https://access.redhat.com/errata/RHSA-2026:44481 Third Party Advisory
- https://access.redhat.com/errata/RHSA-2026:46836 Third Party Advisory
- https://access.redhat.com/errata/RHSA-2026:58981 access.redhat.com
- https://access.redhat.com/security/cve/CVE-2026-42055 Third Party Advisory
- https://bugzilla.redhat.com/show_bug.cgi?id=2489866 Issue Tracking, Third Party Advisory
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-42055.json Third Party Advisory