CVEvulnerability
CVE-2026-42189
7.5 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-05-08
- Last modified
- 2026-10-26
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-770, CWE-789
Description
Russh is a Rust SSH client & server library. Prior to version 0.60.1, a pre-authentication denial-of-service vulnerability exists in the server's keyboard-interactive authentication handler. A malicious client can crash any russh-based server that implements keyboard-interactive auth (e.g., for 2FA/TOTP) with a single malformed packet, requiring no credentials. This issue has been patched in version 0.60.1.
Affected configurations
• russh project russh (< 0.60.1)
• warpgate project warpgate (< 0.23.1)
Related
References
- https://github.com/Eugeny/russh/commit/6c3c80a9b6d60763d6227d60fa8310e57172a4d1 Patch
- https://github.com/Eugeny/russh/releases/tag/v0.60.1 Product, Release Notes
- https://github.com/Eugeny/russh/security/advisories/GHSA-f5v4-2wr6-hqmg Exploit, Mitigation, Vendor Advisory
- https://github.com/Eugeny/russh/security/advisories/GHSA-f5v4-2wr6-hqmg Exploit, Mitigation, Vendor Advisory