CVEvulnerability
CVE-2026-42214
7.8 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-05-07
- Last modified
- 2026-10-26
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.8 HIGH — CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-94
Description
Notepad Next is a cross-platform, reimplementation of Notepad++. Prior to version 0.14, NotepadNext's detectLanguageFromExtension() function interpolates a file's extension directly into a Lua script without sanitization. An attacker can craft a filename whose extension contains Lua code, which executes automatically when the victim opens the file in NotepadNext. Because luaL_openlibs() is called unconditionally, the full os, io, and package libraries are available to the injected code, enabling arbitrary command execution. This issue has been patched in version 0.14.
Affected configurations
• dail8859 notepad next (< 0.14)
Related
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness
References
- https://github.com/dail8859/NotepadNext/commit/f3ca1b10aca52f05fd7f4f5ebf9b566d6cd95ccc Patch
- https://github.com/dail8859/NotepadNext/releases/tag/v0.14 Release Notes
- https://github.com/dail8859/NotepadNext/security/advisories/GHSA-m5fq-c9x5-w54g Exploit, Mitigation, Vendor Advisory
- https://github.com/dail8859/NotepadNext/security/advisories/GHSA-m5fq-c9x5-w54g Exploit, Mitigation, Vendor Advisory