CVEvulnerability
CVE-2026-42225
8.2 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-05-07
- Last modified
- 2026-10-26
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 8.2 HIGH — CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 5.9 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-295
Description
PJSIP is a free and open source multimedia communication library written in C. Prior to version 2.17, on GnuTLS builds, the SIP TLS transport (sip_transport_tls) can accept connections with invalid or untrusted certificates even when the application explicitly enables certificate verification via verify_server = PJ_TRUE or verify_client = PJ_TRUE. This issue has been patched in version 2.17.
Affected configurations
• teluu pjsip (< 2.17)
Related
Weakness · CWE (1)
- CWE-295 Improper Certificate Validation weakness
References
- https://github.com/pjsip/pjproject/commit/ef684252bb62b0716675b6e99ad7fe4c90e28920 Patch
- https://github.com/pjsip/pjproject/releases/tag/2.17 Product, Release Notes
- https://github.com/pjsip/pjproject/security/advisories/GHSA-x2fv-6j6c-pxmx Patch, Vendor Advisory