CVEvulnerability

CVE-2026-42266

8.8 HIGH Published 2026-05-13 Modified 2026-08-28 Official page ↗
Status
Modified
Published
2026-05-13
Last modified
2026-08-28
Assigner
[email protected]
CVSS 3.1 ([email protected])
8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 3.1 (0b0ca135-0b70-47e7-9f44-1890c2a1c46c)
8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-602, CWE-88

Description

JupyterLab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. From 4.0.0 to 4.5.6, the allow-list of extensions that can be installed from PyPI Extension Manager (allowed_extensions_uris) is not correctly enforced by JupyterLab. The PyPI Extension Manager was not contained to packages listed on the default PyPI index. This vulnerability is fixed in 4.5.7.

Affected configurations

• jupyter jupyterlab (>= 4.0.0 < 4.5.7)

Related

Weakness · CWE (2)

  • CWE-602 Client-Side Enforcement of Server-Side Security weakness
  • CWE-88 Improper Neutralization of Argument Delimiters in a Command weakness

References