CVEvulnerability
CVE-2026-42271
CISA Known Exploited Vulnerability
BerriAI LiteLLM Command Injection Vulnerability — BerriAI LiteLLM
BerriAI LiteLLM contains a command injection vulnerability that could allow any authenticated user, including holders of low-privilege internal-user keys, to run arbitrary commands on the host.
- Added to KEV
- 2026-06-08
- Remediation due
- 2026-06-22
- Ransomware use
- Unknown
- Required action
- Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
- Notes
- This vulnerability affects a common open-source component, third-party library, or a protocol used by different products. Please check with specific vendors for information on patching status. For more information, please see: https://github.com/BerriAI/litellm/security/advisories/GHSA-v4p8-mg3p-g94g ; https://github.com/BerriAI/litellm/releases/tag/v1.83.7-stable ; https://nvd.nist.gov/vuln/detail/CVE-2026-42271
- Status
- Analyzed
- Published
- 2026-05-08
- Last modified
- 2026-10-26
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 8.7 HIGH — CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CVSS 3.1 (0b0ca135-0b70-47e7-9f44-1890c2a1c46c)
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-77, CWE-78
Description
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.74.2 to before version 1.83.7, two endpoints used to preview an MCP server before saving it — POST /mcp-rest/test/connection and POST /mcp-rest/test/tools/list — accepted a full server configuration in the request body, including the command, args, and env fields used by the stdio transport. When called with a stdio configuration, the endpoints attempted to connect, which spawned the supplied command as a subprocess on the proxy host with the privileges of the proxy process. The endpoints were gated only by a valid proxy API key, with no role check. Any authenticated user — including holders of low-privilege internal-user keys — could therefore run arbitrary commands on the host. This issue has been patched in version 1.83.7.
Affected configurations
• litellm litellm (>= 1.74.2 < 1.83.7)
• redhat openshift ai (>= 2.25 < 2.25.8)
• redhat openshift ai (>= 3.3 < 3.3.4)
• redhat openshift ai 3.4
Related
References
- https://github.com/BerriAI/litellm/releases/tag/v1.83.7-stable Product, Release Notes
- https://github.com/BerriAI/litellm/security/advisories/GHSA-v4p8-mg3p-g94g Mitigation, Patch, Vendor Advisory
- https://access.redhat.com/errata/RHSA-2026:27784 Third Party Advisory
- https://access.redhat.com/errata/RHSA-2026:28960 Third Party Advisory
- https://access.redhat.com/errata/RHSA-2026:30056 Third Party Advisory
- https://access.redhat.com/security/cve/CVE-2026-42271 Third Party Advisory
- https://bugzilla.redhat.com/show_bug.cgi?id=2467924 Third Party Advisory
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-42271.json Third Party Advisory
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-42271 US Government Resource