CVEvulnerability
CVE-2026-42402
7.5 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-05-01
- Last modified
- 2026-10-26
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-400
Description
Apache Neethi is vulnerable to a Denial of Service attack through algorithmic complexity in policy normalization. Specially crafted WS-Policy documents can trigger an exponential Cartesian cross-product expansion during the normalization process, causing unbounded memory allocation that exhausts the JVM heap. This occurs when the normalization process generates an excessive number of policy alternatives without bounds, leading to runtime memory exhaustion.
Users should upgrade to 3.2.2 which limits the maximum number of normalized policy alternatives.
Affected configurations
• apache neethi (< 3.2.2)
Related
Weakness · CWE (1)
- CWE-400 Uncontrolled Resource Consumption weakness
References
- https://lists.apache.org/thread/p826j0phhmr9f83wzpmys1y0bdfrr2q4 Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2026/05/01/6 Mailing List, Third Party Advisory