CVEvulnerability
CVE-2026-42404
7.2 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-05-01
- Last modified
- 2026-10-26
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- CVSS 3.1 ([email protected])
- 7.2 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-918
Description
Apache Neethi does not impose any restrictions on URIs when manually fetching remote policy references through the PolicyReference API. When an application explicitly calls the API to retrieve a policy from a remote URI, an outbound request is made for arbitrary protocols and internal IP adddresses. From 3.2.2, only http or https URIs are allowed, and link-local/multicast/any-local addresses are forbidden.
Users are recommended to upgrade to version 3.2.2, which fixes this issue.
Affected configurations
• apache neethi (< 3.2.2)
Related
Weakness · CWE (1)
- CWE-918 Server-Side Request Forgery weakness
References
- https://lists.apache.org/thread/zdspnt64zznyjyn648553kptx69w23oq Issue Tracking, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2026/05/01/8 Mailing List, Third Party Advisory