CVEvulnerability
CVE-2026-42509
6.1 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2026-05-06
- Last modified
- 2026-10-26
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.1 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 6.1 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Wicket.
This issue affects Apache Wicket: from 8.0.0 through 8.17.0, 9.0.0, from 10.0.0 through 10.8.0.
Users are recommended to upgrade to version 10.9.0, which fixes the issue.
Affected configurations
• apache wicket (>= 8.0.0 <= 8.17.0)
• apache wicket (>= 9.0.0 <= 9.22.0)
• apache wicket (>= 10.0.0 < 10.9.0)
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://lists.apache.org/thread/52nrq4tt07gxz4r6sj5gyocz5s6bprjp Vendor Advisory
- http://www.openwall.com/lists/oss-security/2026/05/06/2 Mailing List, Third Party Advisory