CVEvulnerability
CVE-2026-42782
7.2 HIGH
Official page ↗
- Status
- Modified
- Published
- 2026-05-25
- Last modified
- 2026-07-24
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.2 HIGH — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 7.2 HIGH — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-653
Description
Improper Isolation or Compartmentalization vulnerability in Apache Syncope.
An administrator with adequate entitlements for Implementations can create a malicious Groovy class containing untrusted code reaching a non-sandboxed execution path via the class static initializer.
This issue affects Apache Syncope: 3.0 through 3.0.16, 4.0 through 4.0.5, 4.1.0.
Users are recommended to upgrade to version 4.0.6 / 4.1.1, which fix this issue by forcing even the static initializer in Groovy code to run in a sandbox.
Affected configurations
• apache syncope (>= 3.0.0 <= 3.0.16)
• apache syncope (>= 4.0.0 < 4.0.6)
• apache syncope 4.1.0
Related
Weakness · CWE (1)
- CWE-653 Improper Isolation or Compartmentalization weakness
References
- https://lists.apache.org/thread/b869ms0ofrd129f7tgsn9flxgv9ztg2r Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2026/05/25/4 Mailing List, Third Party Advisory