CVEvulnerability
CVE-2026-42797
4.9 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2026-05-25
- Last modified
- 2026-07-24
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 4.9 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-202
Description
Exposure of Sensitive Information Through Data Queries vulnerability in Apache Syncope.
An administrator with adequate entitlements for Derived Schemas can create a malicious JEXL expression which allows any administrator with sufficient entitlements for User read to access User-related security-sensitive information.
This issue affects Apache Syncope: 3.0 through 3.0.16, 4.0 through 4.0.5, 4.1.0.
Users are recommended to upgrade to version 4.0.6 / 4.1.1, which fix this issue by further restricting the JEXL expression definition.
Affected configurations
• apache syncope (>= 3.0.0 <= 3.0.16)
• apache syncope (>= 4.0.0 < 4.0.6)
• apache syncope 4.1.0
Related
Weakness · CWE (1)
- CWE-202 Exposure of Sensitive Information Through Data Queries weakness
References
- https://lists.apache.org/thread/5y7d277sntyytrmxnx2tfjr9ftcpq1s6 Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2026/05/25/5 Mailing List, Third Party Advisory