CVEvulnerability
CVE-2026-42843
8.8 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-05-11
- Last modified
- 2026-10-26
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-863
Description
Grav API Plugin is a RESTful API for Grav CMS that provides full headless access to your site's content, media, configuration, users, and system management. Prior to 1.0.0-beta.15, an insecure direct object reference and logic flaw in the Grav API plugin (UsersController::update) allows any authenticated user with basic API access (api.access) to modify their own permission configuration. An attacker can exploit this to escalate their privileges to Super Administrator (admin.super and api.super), leading to full system compromise and potential RCE. This vulnerability is fixed in 1.0.0-beta.15.
Affected configurations
• getgrav grav-plugin-api 1.0.0
Related
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness
References
- https://github.com/getgrav/grav/security/advisories/GHSA-r945-h4vm-h736 Exploit, Vendor Advisory
- https://github.com/getgrav/grav/security/advisories/GHSA-r945-h4vm-h736 Exploit, Vendor Advisory