CVEvulnerability
CVE-2026-42862
7.6 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-06-08
- Last modified
- 2026-07-23
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 7.6 HIGH — CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 5.0 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:N
- Weaknesses
- CWE-284, CWE-639, CWE-915
Description
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to version 3.1.2, a mass assignment vulnerability exists in the tool update endpoint of FlowiseAI. The endpoint allows authenticated users to modify server-controlled properties such as workspaceId, createdDate, and updatedDate when updating a tool resource. Due to missing server-side validation and authorization checks, an attacker can manipulate the workspaceId field and reassign tools to arbitrary workspaces. This breaks tenant isolation in multi-workspace environments. This issue has been patched in version 3.1.2.
Affected configurations
• flowiseai flowise (< 3.1.2)
Related
References
- https://github.com/FlowiseAI/Flowise/releases/tag/flowise%403.1.2 Product, Release Notes
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-x5v6-pj28-cwwm Exploit, Vendor Advisory
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-x5v6-pj28-cwwm Exploit, Vendor Advisory