CVEvulnerability

CVE-2026-4296

7.5 HIGH Published 2026-04-21 Modified 2026-10-26 Official page ↗
Status
Analyzed
Published
2026-04-21
Last modified
2026-10-26
Assigner
[email protected]
CVSS 4.0 ([email protected])
7.5 HIGH — CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1 ([email protected])
8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-185

Description

An incorrect regular expression vulnerability was identified in GitHub Enterprise Server that allowed an attacker to bypass OAuth redirect URI validation. An attacker with knowledge of a first-party OAuth application's registered callback URL could craft a malicious authorization link that, when clicked by a victim, would redirect the OAuth authorization code to an attacker-controlled domain. This could allow the attacker to gain unauthorized access to the victim's account with the scopes granted to the OAuth application. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.21 and was fixed in versions 3.20.1, 3.19.5, 3.18.8, 3.17.14, 3.16.17, 3.15.21, 3.14.26. This vulnerability was reported via the GitHub Bug Bounty program.

Affected configurations

• github enterprise server (< 3.14.26) • github enterprise server (>= 3.15.0 < 3.15.21) • github enterprise server (>= 3.16.0 < 3.16.17) • github enterprise server (>= 3.17.0 < 3.17.14) • github enterprise server (>= 3.18.0 < 3.18.8) • github enterprise server (>= 3.19.0 < 3.19.5) • github enterprise server 3.20.0

Related

Weakness · CWE (1)

  • CWE-185 Incorrect Regular Expression weakness

References