CVEvulnerability
CVE-2026-43914
9.8 CRITICAL
Official page ↗
- Status
- Analyzed
- Published
- 2026-05-11
- Last modified
- 2026-10-26
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.3 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-307
Description
Vaultwarden is a Bitwarden-compatible server written in Rust. Prior to 1.35.4, there is a security vulnerability in Vaultwarden that allows bypassing the login brute-force protection if email 2fa is enabled. If email 2fa is enabled, the unprotected 2fa-function send_email_login (email.rs, api endpoint /api/two-factor/send-email-login) also acts as an oracle determining whether a username-password combination is correct. An attacker can abuse that endpoint to brute-force passwords without rate-limiting. This works even for users who don't have email 2fa configured. This vulnerability is fixed in 1.35.4.
Affected configurations
• dani-garcia vaultwarden (< 1.35.4)
Related
Weakness · CWE (1)
- CWE-307 Improper Restriction of Excessive Authentication Attempts weakness
References
- https://github.com/dani-garcia/vaultwarden/pull/6867 Issue Tracking, Patch
- https://github.com/dani-garcia/vaultwarden/releases/tag/1.35.4 Product, Release Notes
- https://github.com/dani-garcia/vaultwarden/security/advisories/GHSA-c5rv-q295-7w4g Exploit, Patch, Vendor Advisory
- https://github.com/dani-garcia/vaultwarden/security/advisories/GHSA-c5rv-q295-7w4g Exploit, Patch, Vendor Advisory