CVEvulnerability

CVE-2026-43944

9.4 CRITICAL Published 2026-05-08 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2026-05-08
Last modified
2026-06-17
Assigner
[email protected]
CVSS 4.0 ([email protected])
9.4 CRITICAL — CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1 ([email protected])
9.6 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
Weaknesses
CWE-20, CWE-829, CWE-94

Description

electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. From versions 3.0.6 to before 3.8.15, electerm is vulnerable to arbitrary local code execution via deep links, CLI --opts, or crafted shortcuts. Exploit requires clicking a crafted electerm://... link or opening a crafted shortcut/command that launches electerm with attacker-controlled opts. This issue has been patched in version 3.8.15.

Affected configurations

• electerm project electerm (>= 3.0.6 < 3.8.15)

Related

Weakness · CWE (3)

  • CWE-20 Improper Input Validation weakness
  • CWE-829 Inclusion of Functionality from Untrusted Control Sphere weakness
  • CWE-94 Improper Control of Generation of Code weakness

References