CVEvulnerability
CVE-2026-44046
2.3 LOW
Official page ↗
- Status
- Analyzed
- Published
- 2026-06-19
- Last modified
- 2026-10-26
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 2.3 LOW — CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 5.8 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:N
- Weaknesses
- CWE-348
Description
Use of Less Trusted Source vulnerability in Apache APISIX.
Attacker can take advantage of wolf-rbac plugin under default configuration to potentially pollute logs with spoofed identity information and exploit IP based access control rules.
This issue affects Apache APISIX: from 1.2.0 through 3.16.0.
Users are recommended to upgrade to version 3.17.0, which fixes the issue.
Affected configurations
• apache apisix (>= 1.2 < 3.17.0)
Related
Weakness · CWE (1)
- CWE-348 Use of Less Trusted Source weakness
References
- https://lists.apache.org/thread/xkshmps51b24yw0qckl5h5ddyv0x6qf9 Vendor Advisory, Mailing List
- http://www.openwall.com/lists/oss-security/2026/06/19/6 Third Party Advisory