CVEvulnerability
CVE-2026-44160
7.5 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-07-08
- Last modified
- 2026-10-25
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-409
Description
Fluentd collects events from various data sources and writes them to files, RDBMS, NoSQL, IaaS, SaaS, Hadoop and so on. Prior to 1.19.3, Fluentd's in_http and in_forward plugins support gzip-compressed data but enforce limits only on compressed payloads through settings such as body_size_limit and chunk_size_limit, allowing crafted compressed payloads to decompress in memory to an excessive size and cause denial of service through memory exhaustion. This issue is fixed in version 1.19.3.
Affected configurations
• fluentd fluentd (< 1.19.3)
Related
Weakness · CWE (1)
- CWE-409 Improper Handling of Highly Compressed Data (Data Amplification) weakness
References
- https://github.com/fluent/fluentd/commit/f5f2b7cddf8aab3932e6dec9fa367a5f3eb27e10 Patch
- https://github.com/fluent/fluentd/pull/5393 Issue Tracking, Patch
- https://github.com/fluent/fluentd/releases/tag/v1.19.3 Product, Release Notes
- https://github.com/fluent/fluentd/security/advisories/GHSA-j9cw-hwqf-85w7 Mitigation, Vendor Advisory