CVEvulnerability

CVE-2026-44166

6.1 MEDIUM Published 2026-05-12 Modified 2026-06-17 Official page ↗
Status
Analyzed
Published
2026-05-12
Last modified
2026-06-17
Assigner
[email protected]
CVSS 4.0 ([email protected])
6.1 MEDIUM — CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:H/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1 ([email protected])
7.6 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:H/A:L
Weaknesses
CWE-287

Description

Pocketbase is an open source web backend written in go. Prior to 0.22.42 and 0.37.4, in some situations, if an attacker knows the email address of the victim they can create and link an unverified PocketBase user in advance by authenticating with one of the OAuth2 app providers, e.g. "A". When the victim gets invited or decides to sign up to your app on their own with provider "B" (PocketBase OAuth2 auth requires to be with a different provider because we don't allow multiple OAuth2 accounts from the same provider to be associated to a single PocketBase user), the user created previously by the attacker will be autolinked, upgraded to "verified" and its old password reset. This vulnerability is fixed in 0.22.42 and 0.37.4.

Affected configurations

• pocketbase pocketbase (< 0.22.42) • pocketbase pocketbase (>= 0.23.0 < 0.37.4)

Related

Weakness · CWE (1)

  • CWE-287 Improper Authentication weakness

References