CVEvulnerability
CVE-2026-44194
9.1 CRITICAL
Official page ↗
- Status
- Analyzed
- Published
- 2026-05-13
- Last modified
- 2026-10-26
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 9.1 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
- Weaknesses
- CWE-78
Description
OPNsense is a FreeBSD based firewall and routing platform. Prior to 26.1.8, an authenticated Remote Code Execution (RCE) vulnerability in the OPNsense core allows a user with user-management privileges to execute arbitrary system commands as root. An attacker can bypass input validation by formatting their malicious payload as a compliant email address, allowing shell commands to reach the underlying operating system. The flaw exists in the local user synchronization flow, within core/src/opnsense/scripts/auth/sync_user.php. This vulnerability is fixed in 26.1.8.
Affected configurations
• opnsense opnsense (< 26.1.8)
Related
Weakness · CWE (1)
- CWE-78 Improper Neutralization of Special Elements used in an OS Command weakness
References
- https://github.com/opnsense/core/security/advisories/GHSA-f59w-m967-9rf6 Exploit, Mitigation, Vendor Advisory
- https://github.com/opnsense/core/security/advisories/GHSA-f59w-m967-9rf6 Exploit, Mitigation, Vendor Advisory