CVEvulnerability
CVE-2026-44222
7.5 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-05-12
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-129
Description
vLLM is an inference and serving engine for large language models (LLMs). From 0.6.1 to before 0.20.0, there is a a Token Injection vulnerability in vLLM’s multimodal processing. Unauthenticated, text-only prompts that spell special tokens are interpreted as control. Image and video placeholder sequences supplied without matching data cause vLLM to index into empty grids during input-position computation, raising an unhandled IndexError and terminating the worker or degrading availability. Multimodal paths that rely on image_grid_thw/video_grid_thw are affected. This vulnerability is fixed in 0.20.0.
Affected configurations
• vllm vllm (>= 0.6.1 < 0.20.0)
Related
Weakness · CWE (1)
- CWE-129 Improper Validation of Array Index weakness
References
- https://github.com/vllm-project/vllm/issues/32656 Issue Tracking
- https://github.com/vllm-project/vllm/security/advisories/GHSA-hpv8-x276-m59f Exploit, Vendor Advisory