CVEvulnerability
CVE-2026-44574
8.1 HIGH
Official page ↗
- Status
- Modified
- Published
- 2026-05-13
- Last modified
- 2026-10-26
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.1 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- CVSS 3.1 (0b0ca135-0b70-47e7-9f44-1890c2a1c46c)
- 8.1 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-288, CWE-551
Description
Next.js is a React framework for building full-stack web applications. From 15.4.0 to before 15.5.16 and 16.2.5, applications that rely on middleware to protect dynamic routes can be vulnerable to authorization bypass. In affected deployments, specially crafted query parameters can alter the dynamic route value seen by the page while leaving the visible path unchanged, which can allow protected content to be rendered without passing the expected middleware check. This vulnerability is fixed in 15.5.16 and 16.2.5.
Affected configurations
• vercel next.js (>= 15.4.0 < 15.5.16)
• vercel next.js (>= 16.0.0 < 16.2.5)
Related
References
- https://github.com/vercel/next.js/security/advisories/GHSA-492v-c6pp-mqqv Vendor Advisory
- https://access.redhat.com/errata/RHSA-2026:34608 access.redhat.com
- https://access.redhat.com/errata/RHSA-2026:37272 access.redhat.com
- https://access.redhat.com/errata/RHSA-2026:40974 access.redhat.com
- https://access.redhat.com/errata/RHSA-2026:54435 access.redhat.com
- https://access.redhat.com/security/cve/CVE-2026-44574 access.redhat.com
- https://bugzilla.redhat.com/show_bug.cgi?id=2477207 bugzilla.redhat.com
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-44574.json security.access.redhat.com