CVEvulnerability

CVE-2026-44578

8.6 HIGH Published 2026-05-13 Modified 2026-10-26 Official page ↗
Status
Modified
Published
2026-05-13
Last modified
2026-10-26
Assigner
[email protected]
CVSS 3.1 ([email protected])
8.6 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
CVSS 3.1 (0b0ca135-0b70-47e7-9f44-1890c2a1c46c)
8.6 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
Weaknesses
CWE-918

Description

Next.js is a React framework for building full-stack web applications. From 13.4.13 to before 15.5.16 and 16.2.5, self-hosted applications using the built-in Node.js server can be vulnerable to server-side request forgery through crafted WebSocket upgrade requests. An attacker can cause the server to proxy requests to arbitrary internal or external destinations, which may expose internal services or cloud metadata endpoints. Vercel-hosted deployments are not affected. This vulnerability is fixed in 15.5.16 and 16.2.5.

Affected configurations

• vercel next.js (>= 13.4.13 < 15.5.16) • vercel next.js (>= 16.0.0 < 16.2.5)

Related

Weakness · CWE (1)

  • CWE-918 Server-Side Request Forgery weakness

References