CVEvulnerability
CVE-2026-44580
6.1 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2026-05-13
- Last modified
- 2026-10-26
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.1 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
Description
Next.js is a React framework for building full-stack web applications. From 13.0.0 to before 15.5.16 and 16.2.5, applications that use beforeInteractive scripts together with untrusted content can be vulnerable to cross-site scripting. In affected versions, serialized script content was not escaped safely before being embedded into the document, which could allow attacker-controlled input to break out of the intended script context and execute arbitrary JavaScript in a visitor's browser. This vulnerability is fixed in 15.5.16 and 16.2.5.
Affected configurations
• vercel next.js (>= 13.0.0 < 15.5.16)
• vercel next.js (>= 16.0.0 < 16.2.5)
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/vercel/next.js/security/advisories/GHSA-gx5p-jg67-6x7h Mitigation, Vendor Advisory