CVEvulnerability
CVE-2026-44582
3.7 LOW
Official page ↗
- Status
- Analyzed
- Published
- 2026-05-13
- Last modified
- 2026-10-26
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 3.7 LOW — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-328
Description
Next.js is a React framework for building full-stack web applications. From 13.4.6 to before 15.5.16 and 16.2.5, React Server Component responses can be vulnerable to cache poisoning in deployments that rely on shared caches with insufficient response partitioning. In affected conditions, collisions in the _rsc cache-busting value can allow an attacker to poison cache entries so users receive the wrong response variant for a given URL. This vulnerability is fixed in 15.5.16 and 16.2.5.
Affected configurations
• vercel next.js (>= 13.4.6 < 15.5.16)
• vercel next.js (>= 16.0.0 < 16.2.5)
Related
Weakness · CWE (1)
- CWE-328 Use of Weak Hash weakness
References
- https://github.com/vercel/next.js/security/advisories/GHSA-vfv6-92ff-j949 Mitigation, Vendor Advisory