CVEvulnerability
CVE-2026-44728
7.8 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-05-26
- Last modified
- 2026-07-24
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.2 HIGH — CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
- CVSS 3.1 ([email protected])
- 7.8 HIGH — CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-843, CWE-94
Description
Babel is a compiler for writing next generation JavaScript. From 7.12.0 to before 7.29.4 and 8.0.0-alpha.13, using Babel to compile code that was specifically crafted by an attacker can cause Babel to generate output code that executes arbitrary code. This vulnerability is fixed in 7.29.4 and 8.0.0-alpha.13.
Affected configurations
• babel babel (>= 7.12.0 < 7.29.4)
• babel babel 8.0.0
Related
References
- https://github.com/babel/babel/security/advisories/GHSA-fv7c-fp4j-7gwp Mitigation, Vendor Advisory