CVEvulnerability
CVE-2026-45205
5.3 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2026-05-14
- Last modified
- 2026-10-26
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 5.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- Weaknesses
- CWE-674
Description
Uncontrolled Recursion vulnerability in Apache Commons.
When processing an untrusted configuration file, Commons Configuration will throw a StackOverflowError for YAML input with cycles.
This issue affects Apache Commons: from 2.2 before 2.15.0.
Users are recommended to upgrade to version 2.15.0, which fixes the issue.
Affected configurations
• apache commons configuration (>= 2.2 < 2.15.0)
Related
Weakness · CWE (1)
- CWE-674 Uncontrolled Recursion weakness
References
- https://github.com/apache/commons-configuration/pull/634 Issue Tracking, Patch
- https://lists.apache.org/thread/q3q3j10ohcqhs6o0rg1v7kz6kk27vtkk Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2026/05/14/5 Mailing List, Third Party Advisory