CVEvulnerability
CVE-2026-45691
5.9 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2026-06-01
- Last modified
- 2026-07-22
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 5.9 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:H/A:N
- Weaknesses
- CWE-287
Description
Nextcloud is an open source content collaboration platform. In Nextcloud Server from versions 32.0.0 to before 32.0.9, and 33.0.0 to before 33.0.3, a pre-2FA session cookie (created after successful password authentication but before TOTP completion) could be reused as a Bearer token to authenticate against DAV endpoints, granting read/write access and bypassing mandatory two-factor authentication. It is recommended that the Nextcloud Server is upgraded to 33.0.3 or 32.0.9. It is recommended that the Nextcloud Enterprise Server is upgraded to 33.0.3, 32.0.9, 31.0.14.5, 30.0.17.9 or 29.0.16.16
Affected configurations
• nextcloud nextcloud server (>= 32.0.0 < 32.0.9)
• nextcloud nextcloud server (>= 33.0.0 < 33.0.3)
• nextcloud nextcloud server (>= 29.0.0 < 29.0.16.16)
• nextcloud nextcloud server (>= 30.0.0 < 30.0.17.9)
• nextcloud nextcloud server (>= 31.0.0 < 31.0.14.5)
Related
Weakness · CWE (1)
- CWE-287 Improper Authentication weakness
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-mp6x-g55j-w9jw Vendor Advisory
- https://github.com/nextcloud/server/pull/59758 Issue Tracking, Patch
- https://hackerone.com/reports/3573399 Permissions Required