CVEvulnerability
CVE-2026-45692
3.8 LOW
Official page ↗
- Status
- Modified
- Published
- 2026-06-23
- Last modified
- 2026-10-25
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 5.4 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- CVSS 3.1 ([email protected])
- 3.8 LOW — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N
- Weaknesses
- CWE-187, CWE-863
Description
Caddy is an extensible server platform that uses TLS by default. From 2.4.0 until 2.11.3, the authorization layer and the /config traversal layer do not agree on what object the path refers to. In this case, a path authorized for one config object is accepted, but then resolves to a different config object during traversal. This happens because the authorization layer uses string prefix matching and the /config traversal layer parses array indices numerically using strconv.Atoi(). This vulnerability is fixed in 2.11.3.
Affected configurations
• caddyserver caddy (>= 2.4.0 < 2.11.3)
Related
References
- https://github.com/caddyserver/caddy/security/advisories/GHSA-x5w9-xh9r-mvfc Exploit, Vendor Advisory
- https://github.com/caddyserver/caddy/security/advisories/GHSA-x5w9-xh9r-mvfc Exploit, Vendor Advisory