CVEvulnerability
CVE-2026-45815
7.5 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-07-24
- Last modified
- 2026-10-24
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-617
Description
Reachable Assertion vulnerability in Apache NimBLE.
A specially crafted ATT Read Multiple Variable Response (BLE_ATT_OP_READ_MULT_VAR_RSP) may trigger assert in ATT parser.
Severity is medium as this requires DUT to first send ATT Read Multiple Variable Request.
This issue affects Apache NimBLE: through 1.9.0.
Users are recommended to upgrade to version 1.10.0, which fixes the issue.
Affected configurations
• apache nimble (< 1.10.0)
Related
Weakness · CWE (1)
- CWE-617 Reachable Assertion weakness
References
- https://github.com/apache/mynewt-nimble/commit/fae6a4874309ba0175d2c444e20f8a6bde007425 Patch
- https://lists.apache.org/thread/3d09hgo5zmm7dnryst3tb9857hk1bbos Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2026/07/24/14 Mailing List, Third Party Advisory