CVEvulnerability
CVE-2026-46440
9.1 CRITICAL
Official page ↗
- Status
- Analyzed
- Published
- 2026-06-08
- Last modified
- 2026-07-23
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 9.1 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- CVSS 3.0 ([email protected])
- 7.5 HIGH — CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-522
Description
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to version 3.1.2, the checkBasicAuth endpoint validates credentials in plaintext without rate limiting and with direct comparison. This issue has been patched in version 3.1.2.
Affected configurations
• flowiseai flowise (< 3.1.2)
Related
Weakness · CWE (1)
- CWE-522 Insufficiently Protected Credentials weakness
References
- https://github.com/FlowiseAI/Flowise/releases/tag/flowise%403.1.2 Product, Release Notes
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-php6-83fg-gw3g Mitigation, Vendor Advisory
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-php6-83fg-gw3g Mitigation, Vendor Advisory