CVEvulnerability

CVE-2026-46605

4.3 MEDIUM Published 2026-06-01 Modified 2026-07-22 Official page ↗
Status
Analyzed
Published
2026-06-01
Last modified
2026-07-22
Assigner
[email protected]
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
4.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
Weaknesses
CWE-285

Description

Incomplete authorization by Apache ActiveMQ server before versions v6.2.6 and v5.19.7 allows authenticated connections to remove existing destinations with proper permissions. This issue affects Apache ActiveMQ Broker: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ All: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6. Users are recommended to upgrade to version v6.2.6 or v5.19.7, which fixes the issue.

Affected configurations

• apache activemq (< 5.19.7) • apache activemq (>= 6.0.0 < 6.2.6) • apache activemq broker (< 5.19.7) • apache activemq broker (>= 6.0.0 < 6.2.6)

Related

Weakness · CWE (1)

  • CWE-285 Improper Authorization weakness

References