CVEvulnerability
CVE-2026-48093
6.5 MEDIUM
Official page ↗
- Status
- Deferred
- Published
- 2026-08-07
- Last modified
- 2026-09-09
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L
- Weaknesses
- CWE-79
Description
The Code Embed WordPress plugin prior to version 2.6.1 is vulnerable to stored Cross-Site Scripting (XSS) through the external URL embed feature in post content. The vulnerable code scans rendered content for URL embed tokens, fetches the remote URL, and inserts the remote response body into the page without output sanitization or an `unfiltered_html` capability check. This allows a Contributor attacker to submit a pending post containing an inert-looking URL token that executes attacker-controlled JavaScript when an Administrator or Editor previews or reviews the post. This is distinct from CVE-2026-2512, which affected custom field meta values up to version 2.5.1. This vector affects version 2.6 and uses the documented external URL embed feature in post content. This particular issue is patched in version 2.6.1.
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/dartiss/code-embed/commit/399752029c62fea82a9bc13fd156713fb4d50ea8 github.com
- https://github.com/dartiss/code-embed/releases/tag/2.6.1 github.com
- https://github.com/dartiss/code-embed/security/advisories/GHSA-7c9x-px5v-5hcp github.com
- https://github.com/dartiss/code-embed/security/advisories/GHSA-7c9x-px5v-5hcp github.com