CVEvulnerability

CVE-2026-48746

9.1 CRITICAL Published 2026-06-22 Modified 2026-10-25 Official page ↗
Status
Modified
Published
2026-06-22
Last modified
2026-10-25
Assigner
[email protected]
CVSS 3.1 ([email protected])
9.1 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
CVSS 3.1 (0b0ca135-0b70-47e7-9f44-1890c2a1c46c)
9.1 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
Weaknesses
CWE-444, CWE-501

Description

vLLM is an inference and serving engine for large language models (LLMs). From 0.3.0 until 0.22.0, a vulnerability in ASGI web servers and starlette's trust on those web servers enables an authentication bypass of the OpenAI API AuthenticationMiddleware. It allows to use the API without providing the configured VLLM_API_KEY or --api-key. This vulnerability is fixed in 0.22.0.

Affected configurations

• vllm vllm (>= 0.3.0 < 0.22.0)

Related

Weakness · CWE (2)

  • CWE-444 Inconsistent Interpretation of HTTP Requests weakness
  • CWE-501 Trust Boundary Violation weakness

References