CVEvulnerability
CVE-2026-48773
9.8 CRITICAL
Official page ↗
- Status
- Analyzed
- Published
- 2026-06-19
- Last modified
- 2026-10-25
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-787
Description
ProxySQL is a proxy for MySQL and its forks, as well as PostgreSQL. Versions 2.0.18 through 3.0.8 have a pre-authentication heap memory corruption vulnerability in the MySQL and PostgreSQL protocol first-read paths. A remote unauthenticated client can declare an oversized first packet length, and ProxySQL passes that attacker-controlled length directly to `recv()` while writing into a fixed 32 KB input queue. Version 3.0.9 patches the issue.
Affected configurations
• proxysql proxysql (>= 2.0.18 < 3.0.9)
Related
Weakness · CWE (1)
- CWE-787 Out-of-bounds Write weakness
References
- https://github.com/sysown/proxysql/releases/tag/v3.0.9 Release Notes
- https://github.com/sysown/proxysql/security/advisories/GHSA-58ww-865x-grpr Exploit, Mitigation, Vendor Advisory
- https://github.com/sysown/proxysql/security/advisories/GHSA-58ww-865x-grpr Exploit, Mitigation, Vendor Advisory