CVEvulnerability

CVE-2026-49042

7.3 HIGH Published 2026-07-06 Modified 2026-10-25 Official page ↗
Status
Analyzed
Published
2026-07-06
Last modified
2026-10-25
Assigner
[email protected]
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
7.3 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weaknesses
CWE-20

Description

Improper Input Validation vulnerability in Apache Camel. This issue affects Apache Camel: from 4.8.0 through 4.18.2, from 4.19.0 through 4.20.0. Users are recommended to upgrade to version 4.18.3, 4.21.0, which fixes the issue.

Affected configurations

• apache camel (>= 4.8.0 < 4.18.3) • apache camel (>= 4.19.0 < 4.21.0)

Related

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References