CVEvulnerability
CVE-2026-49157
8.8 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-06-01
- Last modified
- 2026-07-22
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-276
Description
Incorrect Default Permissions vulnerability in Apache ActiveMQ.
This issue affects Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6.
The default Jolokia authorization settings granted non-admin (low-privilege) web-login accounts access to Jolokia operations which allowed executing broker management operations meant for admins such as addQueue and removeQueue.
Users are recommended to upgrade to version 6.2.6 or 5.19.7, which fixes the issue.
Affected configurations
• apache activemq (< 5.19.7)
• apache activemq (>= 6.0.0 < 6.2.6)
Related
Weakness · CWE (1)
- CWE-276 Incorrect Default Permissions weakness
References
- https://lists.apache.org/thread/rrcsf6s90hj4tdh89nvkko75q5505rj8 Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2026/05/31/21 Mailing List, Third Party Advisory