CVEvulnerability
CVE-2026-49158
7.5 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-07-27
- Last modified
- 2026-10-24
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-409
Description
Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Ruby bindings.
This issue affects Apache Thrift: before 0.24.0.
Users are recommended to upgrade to version 0.24.0, which fixes the issue.
Affected configurations
• apache thrift (< 0.24.0)
Related
Weakness · CWE (1)
- CWE-409 Improper Handling of Highly Compressed Data (Data Amplification) weakness
References
- https://lists.apache.org/thread/7v3jhgwfbmhx42424phydlnzb109g8b9 Release Notes
- https://lists.apache.org/thread/fmjl8l415tj9zwlob8v2dr5hq1d0hts7 Vendor Advisory
- http://www.openwall.com/lists/oss-security/2026/07/24/38 Mailing List, Third Party Advisory