CVEvulnerability
CVE-2026-49230
6.3 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2026-06-19
- Last modified
- 2026-10-25
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 6.3 MEDIUM — CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 9.1 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-354
Description
Improper Validation of Integrity Check Value vulnerability in Apache APISIX.
The jwe-decrypt plugin under default configuration is vulnerable to authentication bypass.
This issue affects Apache APISIX: from 3.8.0 through 3.16.0.
Users are recommended to upgrade to version 3.17.0, which fixes the issue.
Affected configurations
• apache apisix (>= 3.8.0 < 3.17.0)
Related
Weakness · CWE (1)
- CWE-354 Improper Validation of Integrity Check Value weakness
References
- https://lists.apache.org/thread/n0blgkpvz38ghh5rrh6wtl476919xj1b Vendor Advisory, Mailing List
- http://www.openwall.com/lists/oss-security/2026/06/19/12 Third Party Advisory