CVEvulnerability

CVE-2026-49434

7.5 HIGH Published 2026-06-30 Modified 2026-07-02 Official page ↗
Status
Analyzed
Published
2026-06-30
Last modified
2026-07-02
Assigner
[email protected]
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weaknesses
CWE-20

Description

Improper Input Validation vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All. An attacker that has access to publish or modify entries in LDAP that match the configured searchBase and searchFilter can instantiate denied transports inside the broker JVM. This can be used to fetch an attacker URL and spawn a second BrokerService inside the same JVM. This issue affects Apache ActiveMQ Broker: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ All: before 5.19.8, from 6.0.0 before 6.2.7. Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.

Affected configurations

• apache activemq (< 5.19.8) • apache activemq (>= 6.0.0 < 6.2.7) • apache activemq broker (< 5.19.8) • apache activemq broker (>= 6.0.0 < 6.2.7)

Related

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References