CVEvulnerability
CVE-2026-49477
7.5 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-07-14
- Last modified
- 2026-10-24
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-1333, CWE-400
Description
Soup Sieve is a CSS selector library designed to be used with Beautiful Soup 4. Prior to 2.8.4, the CSS selector parser in soupsieve contains a regular expression vulnerable to catastrophic backtracking when processing an attribute selector with an unterminated quoted value in soupsieve/css_parser.py, allowing an attacker who can supply untrusted CSS selector strings to soupsieve.compile() or Beautiful Soup .select() / .select_one() to cause CPU exhaustion and denial of service. This issue is fixed in version 2.8.4.
Affected configurations
• facelessuser soup sieve (< 2.8.4)
Related
References
- https://github.com/facelessuser/soupsieve/commit/eb4397618709186c109400448c6043b728217dc3 Patch
- https://github.com/facelessuser/soupsieve/releases/tag/2.8.4 Release Notes
- https://github.com/facelessuser/soupsieve/security/advisories/GHSA-836r-79rf-4m37 Exploit, Vendor Advisory
- https://github.com/facelessuser/soupsieve/security/advisories/GHSA-836r-79rf-4m37 Exploit, Vendor Advisory